Jump to content


Photo

From Milkshape to Modder's Workshop

Milkshape mods addons modders workshop moviestorm help tutorial process textures materials

  • Please log in to reply
9 replies to this topic

#1 madiaba123

madiaba123

    Moviegoer

  • Members
  • 6 posts

Posted 27 January 2015 - 02:53 PM

Hi, i am using moviestorm and it is a great program. Though, I could use some help. I am trying to import an animated snake I have in Milkshape into Moviestorm's "Modder's Wrokshop". I have used Cal3d to export everything and have the folders set up. Once I am in modders workshop everything seems to be going fine. After I add the mesh and materials for the eyes and tongue, it shows up on set. HOWEVER, when I go to add the mesh for the snake body, the camera view puts me way out in "la la" land and all I can see is blue, and there is no way to get back to the grid and axis. A couple of times I was able to get back to the grid, but could not find the eyes, tongue, or the body. This happens EVERY time I try to add the body mesh . Any ideas? Please help :) thank you!



#2 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5373 posts
  • Gender:Male

Posted 27 January 2015 - 07:23 PM

This is usually caused because of an issue with the assignment of vertices. Make sure that every one is assigned to a skeleton bone. Also make sure that you didn't specify a number higher than 4 in the part where you choose how many bones can influence a vertex.

Another possibility is that you have a Milkshape Group which does not have a material assigned. Remember all material names must be of the form "Wood [0]" (with different numbers in square brackets). 

HTH


"If we only use 1/3 of our brain, what's the other 1/3 for?"


#3 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 29 January 2015 - 11:53 AM

Hi, i am using moviestorm and it is a great program. Though, I could use some help. I am trying to import an animated snake I have in Milkshape into Moviestorm's "Modder's Wrokshop". I have used Cal3d to export everything and have the folders set up. Once I am in modders workshop everything seems to be going fine. After I add the mesh and materials for the eyes and tongue, it shows up on set. HOWEVER, when I go to add the mesh for the snake body, the camera view puts me way out in "la la" land and all I can see is blue, and there is no way to get back to the grid and axis. A couple of times I was able to get back to the grid, but could not find the eyes, tongue, or the body. This happens EVERY time I try to add the body mesh . Any ideas? Please help :) thank you!

 

It's likely you are not zoomed out, but instead the renderer is throwing an exception every frame, and never succeeding in rendering anything other than the pale blue background.

 

It's likely that the log.txt is very full of exceptions. Sometimes they provide a hint as to what is going wrong. If you reproduce the error (the log.txt is cleared each time you start Moviestorm), and zip up the resulting log.txt and attach it to a reply, I can have a look, and see if there is anything obviously wrong that might help.

 

Log.txt is found in the Moviestorm user folder.

 

Primveranz' suggestions are very much worth trying, too.


Ben Sanders
Moviestorm Ltd

#4 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5373 posts
  • Gender:Male

Posted 30 January 2015 - 02:17 AM

Another less likely cause is that you have two skeletons in the folder. Or that you have placed the object (with only 1 skeleton) in a folder where it is inheriting the existing skeleton of a parent object, and thus crashing MW.


"If we only use 1/3 of our brain, what's the other 1/3 for?"


#5 madiaba123

madiaba123

    Moviegoer

  • Members
  • 6 posts

Posted 03 February 2015 - 05:57 PM

Thank you all for your help. I figured out the problem, it was in my exporting process AND I believe the object was too High poly. I fixed the poly count and carefully exported and everything is working well.

 

My next question is how do I add multiple animations so that those animation options are available in the directors view in Moviestorm? I added several different animations to the animations folder and they all appear and work in modder's workshop...but they dont show up as options in the director's view in moviestorm.

 

How do I do this?

 

Thank you!



#6 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 04 February 2015 - 02:00 PM

You need to set up transitions for the animations, and then verbs for the animations.

 

A transition specifies that an animation goes from one named state to another. It saves to the StateMachine file in your addon. It's possible to have NEUTRAL states that are not named, too, but the transition still needs to exist. When looking at an animation in the modders workshop, the bottom left panel has the details that go into the transition, and a save button to save it.

 

A verb specifies which animations (and the related transitions) go together; different types of verbs require different types of things to associate. If you have just made a prop and some animations, you would need a 'prop solo' verb.

It also specifies the menu name for the animation.

 

 

It might be worth watching the animations video from Chris Ollis here: http://www.moviestor...odding/modding3

The first bit is about exporting from max, but the latter bits (showing the modders workshop) have an explanation of setting up the animations (note they use a 'character solo' verb rather than a 'prop solo' verb).

 

I've attached something I wrote a long while ago that was aimed at our artists, but is mostly relevant.

 

 

 

 

Attached Files


Ben Sanders
Moviestorm Ltd

#7 madiaba123

madiaba123

    Moviegoer

  • Members
  • 6 posts

Posted 04 February 2015 - 04:45 PM

You need to set up transitions for the animations, and then verbs for the animations.

 

A transition specifies that an animation goes from one named state to another. It saves to the StateMachine file in your addon. It's possible to have NEUTRAL states that are not named, too, but the transition still needs to exist. When looking at an animation in the modders workshop, the bottom left panel has the details that go into the transition, and a save button to save it.

 

A verb specifies which animations (and the related transitions) go together; different types of verbs require different types of things to associate. If you have just made a prop and some animations, you would need a 'prop solo' verb.

It also specifies the menu name for the animation.

 

 

It might be worth watching the animations video from Chris Ollis here: http://www.moviestor...odding/modding3

The first bit is about exporting from max, but the latter bits (showing the modders workshop) have an explanation of setting up the animations (note they use a 'character solo' verb rather than a 'prop solo' verb).

 

I've attached something I wrote a long while ago that was aimed at our artists, but is mostly relevant.

 

 

 

 

 

Thank you!



#8 madiaba123

madiaba123

    Moviegoer

  • Members
  • 6 posts

Posted 11 February 2015 - 07:56 PM

Hello again,

 

I have a question regarding materials and meshes. Is it possible that when i am adding materials and meshes in modder's workshop that a material may not show up because the mesh is too high poly? the materials show up for all the other meshes except for one... trust trying to figure out why.



#9 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5373 posts
  • Gender:Male

Posted 11 February 2015 - 10:06 PM

Assuming the material is correctly named (e.g. with [0] suffix) and assigned to the correct groups in Milkshape, my first thought would be that the texture might be the wrong format or filesize too large.  How many polys is the mesh?


"If we only use 1/3 of our brain, what's the other 1/3 for?"


#10 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5373 posts
  • Gender:Male

Posted 12 February 2015 - 05:03 AM

Oh, and another thing. Don't have any spaces in the material name.


"If we only use 1/3 of our brain, what's the other 1/3 for?"



  • Please log in to reply



Also tagged with one or more of these keywords: Milkshape, mods, addons, modders workshop, moviestorm, help, tutorial, process, textures, materials

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users