Jump to content


Photo

Odd things showing


  • Please log in to reply
7 replies to this topic

#1 Daneel

Daneel

    Upcoming director

  • Members
  • 83 posts

Posted 11 February 2017 - 04:52 PM

Hey all. I'm using the Drunk Collapse and Drunk Amble animations for a couple of scenes in my new effort.

In the first scene, everything is hunky dory but in the second scene two red squares appear behind my drunken character that then move along and around him as he stumbles about.

I assume these are some sort of control dummy object artifacts. Has anyone else used these animations and experienced this? It's quite odd that they appear in one scene and not another but this also gives me some hope that i can remove them.



#2 jamoram62

jamoram62

    Master Director

  • Members
  • 787 posts
  • Gender:Male
  • Location:3724'21.05"N 00559'14.69"W

Posted 11 February 2017 - 05:24 PM

Do you mean the animations by KV? If so I've been unable to reproduce the problem you've described. Maybe a screenshot, a test clip or even a shared movie could be of some help for diagnosing?


ars longa vita brevis - Hippocrates (attributed)
 
If you want to tell jokes then use Muvizu; if you want to make 'Movies', use iClone; but if you want to tell stories, use Moviestorm - PrimaveraNZ
 
Shared addons & stuff for Moviestorm: https://drive.google...aTNsSFBuN0sxZHM


#3 Daneel

Daneel

    Upcoming director

  • Members
  • 83 posts

Posted 11 February 2017 - 07:56 PM

Yes. The KV animations. Thanks. I'll do you a test clip. Can i just attach it onto a thread reply like i would an image?

 

Edit: Seems I'm not permitted to upload a video clip. I tried with a .webm and a .mp4 so I've attached an image. The offenders are ringed in red. They fly around the screen following my drunk characters movements. I too am unable to reproduce the effect. I tried with an empty movie and a single actor but the animations played fine. No artifacts. Could it be something to do with the lighting? Seems unlikely but you never know with these thing do you,

 

Attached Files



#4 jamoram62

jamoram62

    Master Director

  • Members
  • 787 posts
  • Gender:Male
  • Location:3724'21.05"N 00559'14.69"W

Posted 11 February 2017 - 09:39 PM

I've seen things you people wouldn't believe, but this is really odd. I doubt it is directly related to the gait animation, for it's just this: a sequence of skeleton transformations; there are no such thing as dummy objects in MS. But you can't never say.

Does this appear in whatever view you're running the movie (ie, director's, camera, cut room, ...). Also would you mind to include the log file MS recreates every time is launched? Maybe it reports any error or event which may be related.

ars longa vita brevis - Hippocrates (attributed)
 
If you want to tell jokes then use Muvizu; if you want to make 'Movies', use iClone; but if you want to tell stories, use Moviestorm - PrimaveraNZ
 
Shared addons & stuff for Moviestorm: https://drive.google...aTNsSFBuN0sxZHM


#5 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5259 posts
  • Gender:Male

Posted 11 February 2017 - 10:45 PM

I wonder if the reason you see them in one scene and not another is due to them showing their "Backfaces" so it depends what angle you are looking from.

 

Other things to consider are :-

Do they differ if you have shaders switched on and off in the "Settings" options?

Does it make a difference if the lighting is "Directional" as opposed to "Tri-Directional"?


"If we only use 1/3 of our brain, what's the other 1/3 for?"


#6 jamoram62

jamoram62

    Master Director

  • Members
  • 787 posts
  • Gender:Male
  • Location:3724'21.05"N 00559'14.69"W

Posted 12 February 2017 - 11:26 AM

I concur with Prim and I'd say it's some kind of graphics artifact. I'd try different graphic settings (depth of focus, anti-aliasing, rendering, etc). Also the first time MS is launched it generates a report with the hardware capabilities of your graphic card and possible compatibility issues, though right now I can't remember what's the name of the file.

 

EDIT: the files including the report with the info about the capabilities of the graphic card are named hardware-report.html and hardware-report-summary.html; the file with the log info for the session is LOG.txt. They all can be found inside the %UserProfile%\Moviestorm folder.


ars longa vita brevis - Hippocrates (attributed)
 
If you want to tell jokes then use Muvizu; if you want to make 'Movies', use iClone; but if you want to tell stories, use Moviestorm - PrimaveraNZ
 
Shared addons & stuff for Moviestorm: https://drive.google...aTNsSFBuN0sxZHM


#7 Daneel

Daneel

    Upcoming director

  • Members
  • 83 posts

Posted 12 February 2017 - 02:12 PM

OK thanks guys. I'm not able to access the movie currently because my licence has expired but i'll do all the things you've suggested when i renew my licence in a day or two and then get back to you with the findings. It's not the backfaces thing though because i see them which ever angle i view the scene from.



#8 Daneel

Daneel

    Upcoming director

  • Members
  • 83 posts

Posted 15 February 2017 - 08:07 PM

Thanks for all the help and suggestions guys. Primaveranz nailed it with the shaders. I experimented with the different shader options in the settings menu and it turned out the culprit was 'Hardware Skinning'. Turning that off got rid of the flying squares. Anyone know what Hardware Skinning does? Because having it off doesn't seem to make any difference to the images on screen (thankfully).




  • Please log in to reply


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users