Jump to content


Photo

Corruption message


  • Please log in to reply
5 replies to this topic

#1 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5339 posts
  • Gender:Male

Posted 23 August 2013 - 11:00 PM

Ben, what is the trigger for the message saying that it looks like Moviestorm has crashed on a previous running?
I get this every time now after I had one crash and restarted the program. MS seems to run OK but the message is annoying. I'm guessing there is a file or Registry setting that needs deleted or switched off?

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#2 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5339 posts
  • Gender:Male

Posted 02 September 2013 - 04:08 AM

QUOTE (primaveranz @ Aug 24 2013, 11:00 AM) <{POST_SNAPBACK}>
Ben, what is the trigger for the message saying that it looks like Moviestorm has crashed on a previous running?
I get this every time now after I had one crash and restarted the program. MS seems to run OK but the message is annoying. I'm guessing there is a file or Registry setting that needs deleted or switched off?


Bump.

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#3 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 02 September 2013 - 11:14 AM

When Moviestorm starts, it creates a file called launcher.lock in Users/[username]/Moviestorm/.cache
The files contents should show the date and time that Moviestorm was last started.
When it exits correctly, it deletes that file.

When Moviestorm is started, if that file allready exists, then clearly Moviestorm did not exit correctly, and so it either crashed, or is still running.

Experience has shown that the File.deleteOnExit() is not nearly as reliable as one might expect, however.
I will have more of a look at it.

Edit: I had thought I had done some improvements to it in the 1.6.0 beta (making sure the file is closed, to make the deleteOnExit() work better). Do you see any improvements with the beta version?
Ben Sanders
Moviestorm Ltd

#4 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5339 posts
  • Gender:Male

Posted 27 September 2013 - 12:01 AM

QUOTE (Ben_S @ Sep 2 2013, 11:14 PM) <{POST_SNAPBACK}>
Do you see any improvements with the beta version?


Not really if anything it is worse....

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#5 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 27 September 2013 - 02:58 PM

Is the launcher.lock failing to be deleted when you exit Moviestorm normally? When you exit the launcher normally?
Does it have the date it in (if you view it in a text editor)? Or is it empty?
Ben Sanders
Moviestorm Ltd

#6 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5339 posts
  • Gender:Male

Posted 27 September 2013 - 10:05 PM

I tried various tests this morning. Starting to various levels creating new movies and loading old ones and (of course) can't get the problem to reproduce.
So don't waste may more time on it just now. Now I know where the lock file is I can keep a closer watch on it and see if I can discern a pattern.

Thanks wink.gif

"If we only use 1/3 of our brain, what's the other 1/3 for?"



  • Please log in to reply


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users