Jump to content


Photo

Moviestorm 1.7.0 release


  • Please log in to reply
25 replies to this topic

#1 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 10 October 2014 - 02:52 PM

We are releasing Moviestorm 1.7.0 which contains a number of updates that were initially released as a 1.6.4 beta, and a new version of the Launcher, as well as some additional fixes.
Post 1.6.4 beta changes in italics.


Moviestorm 1.7.0

Build Number: 30728
New features

Moviestorm now has a memory monitor in the top right, which shows what proportion of available heap space is being used, and if garbage collection is happening frequently.
Modder's workshop Retexture Wizard now allows retexturing of parts based objects - select a part in the master browser and right click and select retexture.
Dialogue lines and Play Sound activities now show the filename for the audio file.
When inserting time, extra time can be added to held prop containers or gesture containers, to extend future gestures too.
Time can now be removed from the timeline if nothing is happening.
Added a Facial Expression customizer, an alternative to using a Mood Change, which allows you to change the facial expression only.
Moviestorm should now function on case sensitive file systems.
Load backup versions of a movie now has a tick box rather than a separate load button, and works for movies not stored in the default place.
Motion Path activities now have an option to change between constant speed, and having a smooth start and stop (the previous default).
When selecting 'Gesture' with an existing gesture sequence that is unfinished, open the existing gesture sequence rather than creating a new one.
Moviestorm Launcher redesigned.
The default viewpoint for looking at a scene now works the same as centering the viewpoint.
The viewpoint position when looking at a scene is now kept after going to the Cutting Room and back.
The viewpoint position when looking at a scene is now kept after saving and reloading your movie. It is also saved with a stock set.
Using the mousewheel over the timeline now zooms the timeline in or out.
Dragging part of the timeline that does not have any activities will change which part of the timeline is visible (without changing the time).
Content pack names now sorted when shown in the requirements for loading a movie, on the Load Movie screen.
The settings Graphics panel now lets one choose how many lights can affect any object. Previously only 4 lights (three plus the sun) could illuminate something. Using a high value all the time can slow your framerate down - you might want to just turn it up for rendering.
When adding a filter in the Cutting Room, you can now choose a preset when applying the filter to all clips.


Resolved issues

File browsers remember recent folders, even if you canceled the browsing.
Addons from the pre-1.0 version of Moviestorm now work when installed in the user Addon folder.
Walk cycle names are shown in sorted order.
Fix for a problem where videos could not be added to the clip bin in the Director's View (after they had been added in the Cutting Room view)
Trying to create a plain black image to add to the timeline (in the Cutting Room) now produces a black image rather than a white one.
Memory leak relating to buttons in the clip bins in the Cutting Room fixed.
Memory leaks relating to the script editor have been fixed.
Better removal of old movies from memory.
Warning message when old movies have not been removed from memory correctly to advise a restart.
The camera lens slider now shows the lens length based on selected real world camera details.
Sliders with numbers on should be easier to read now.
Fix for some lookat animation snapping that was occuring during improvised looking at the person who was talking.
Taking a camera snapshot now works even if the movie name includes an apostraphy.
Fix for an issue which changed the texture border of a screen when playing video on a different, similar, screen
Scrubbing is a lot faster in some situations.
Deleting clips (video and audio) from the Cutting Room, now also deletes the related files from your saved movie (if you save it).
When displaying the amount of time available to delete, always round it down so that typing in that amount always works.
Fix for a bug that can prevent the Cutting Room from loading, if an image was previously taken from a drive that is no longer available.
When updating the recent folders list (after choosing a file), make sure it saves.
Fixed some issues caused by converting filenames to lowercase in languages with different uppercase/lowercase mappings to English (such as Turkish).
Sorted the different templates when displaying lots of templates for a prop (doors needed this most).
When determining which content packs are used by a character, it is now correctly determining which pack any decals that are used are in, rather than just including all packs that had decals.
The prop browser can be hidden by clicking it's button again.
Images on the Load Movie screen are now reduced to the size shown on the buttons, rather than kept in memory at full size. This could use up a lot of memory if one had a lot of saved movies in the default save folder.
Changing the gait of a character that was walking through a door no longer fails depending on where the timeline marker is.




TownBuildings for Moviestorm 1.7.0

Build Number: 30728
New features

The doors matching those for the Town Buildings now have tintable architraves.



Filters01 for Moviestorm 1.7.0

Build Number: 30728
New features

Changed some filter presets. The Red Cutout and Night Time filters have better named presets with more usable values.



ModdersWorkshop for Moviestorm 1.7.0

Build Number: 30728
New features

Updated door templates from TownBuildings.
Updated Cartoon Tree template.


CartoonWorld for Moviestorm 1.7.0

Build Number: 30728
New features

Cartoon Tree is now scalable.
Ben Sanders
Moviestorm Ltd

#2 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5215 posts
  • Gender:Male

Posted 10 October 2014 - 07:33 PM

Thanks Ben, one step closer to 2.0.0 wink.gif

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#3 writerly

writerly

    Master Director

  • Pioneers
  • 848 posts

Posted 10 October 2014 - 11:42 PM

[quote name='Ben_S' date='Oct 10 2014, 2:52 PM' post='105200']
We are releasing Moviestorm 1.7.0 which contains a number of updates that were initially released as a 1.6.4 beta, and a new version of the Launcher, as well as some additional fixes.
Post 1.6.4 beta changes in italics.

Not gone well thus far...
Will try a clean install and see what happens.
Colour me unhappy.
C

#4 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 11 October 2014 - 12:45 AM

QUOTE (writerly @ Oct 10 2014, 11:42 PM) <{POST_SNAPBACK}>
Not gone well thus far...
Will try a clean install and see what happens.
Colour me unhappy.
C

Sorry about that - what is happening or not happening?
Ben Sanders
Moviestorm Ltd

#5 mattzart30

mattzart30

    Master Director

  • Members
  • 286 posts

Posted 11 October 2014 - 02:57 AM

This is an awesome update - I am thrilled with the new Lights setting in the graphics section! I got one of my wishes!!
smile.gif

#6 writerly

writerly

    Master Director

  • Pioneers
  • 848 posts

Posted 11 October 2014 - 12:20 PM

QUOTE (Ben_S @ Oct 11 2014, 12:45 AM) <{POST_SNAPBACK}>
Sorry about that - what is happening or not happening?

My attempt to upgrade one of my existing installations (I have a Moddersworkshop version, a building version and stripped down shooting version) threw a hissy fit when it couldn't find 3DTree's character base which I have never purchased (bad Writerly).
So far the clean install is progressing albeit with many restarts. It will go so long then just stop loading. I switch it off. Restart and it starts loading again. I'll keep you up to date.
C










#7 Ichikaidan

Ichikaidan

    Critically acclaimed

  • Members
  • 190 posts

Posted 11 October 2014 - 02:03 PM

rolleyes.gif
Thank you very much Ben for your efforts
Beautiful update.
Runs smooth on OSX.
Only one restart for 30728 needed, which it got now as well.
Thanks again and up to 2.0 yes please.
Greets
Creating situations and learning to see.

#8 writerly

writerly

    Master Director

  • Pioneers
  • 848 posts

Posted 11 October 2014 - 02:24 PM

On a clean download install it bog down in the update section.

I get:

download\patch-SpecialEffects-25160.jar (The system cannot find the file specified)

And that's as far as I can get it to go.
I can't start a new movie or load an old movie.
C

#9 alonzo11208

alonzo11208

    Master Director

  • Members
  • 360 posts
  • Gender:Male

Posted 11 October 2014 - 02:56 PM

The launcher looks great!

Will give it a whirl this weekend.
Shadows of Fire
Shadows of Fire Encyclopedia

Creater of Shadows of Fire

#10 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5215 posts
  • Gender:Male

Posted 11 October 2014 - 11:11 PM

Hi Ben, I am getting the attached message. I have 12Gb free disk :-

Attached Files


"If we only use 1/3 of our brain, what's the other 1/3 for?"


#11 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5215 posts
  • Gender:Male

Posted 11 October 2014 - 11:14 PM

That error was when I tried to upgrade from the non-beta version. The upgrade from the Beta version worked fine.

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#12 keithlawrence

keithlawrence

    Master Director

  • Pioneers
  • 1143 posts

Posted 11 October 2014 - 11:46 PM

QUOTE (primaveranz @ Oct 10 2014, 9:33 PM) <{POST_SNAPBACK}>
one step closer to 2.0.0 wink.gif

That`s like beautiful music.
Accompanied with 64-bit, it`s a epical, philharmonic symphony

#13 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 12 October 2014 - 08:43 AM

Writterly, primervaeranz - does restarting the launcher allow it to have another go, and get the download going correctly?

Otherwise I will need more more details and try to sort things out on Monday.
Ben Sanders
Moviestorm Ltd

#14 writerly

writerly

    Master Director

  • Pioneers
  • 848 posts

Posted 12 October 2014 - 02:40 PM

QUOTE (Ben_S @ Oct 12 2014, 8:43 AM) <{POST_SNAPBACK}>
Writterly, primervaeranz - does restarting the launcher allow it to have another go, and get the download going correctly?

Otherwise I will need more more details and try to sort things out on Monday.

Multiple restarts. Always bogs down in the same spot. (Just tried it again to be sure.) What do you need from us to help resolve this?

Regards,
C

#15 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5215 posts
  • Gender:Male

Posted 12 October 2014 - 05:53 PM

QUOTE (Ben_S @ Oct 12 2014, 8:43 PM) <{POST_SNAPBACK}>
Writterly, primervaeranz - does restarting the launcher allow it to have another go, and get the download going correctly?

Restarting MS didn't help but a complete PC restart must have, as it is working OK this morning. Thanks Ben wink.gif

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#16 pedrosura

pedrosura

    Master Director

  • Members
  • 253 posts

Posted 13 October 2014 - 03:13 AM

It worked great!. I already had 1.6.4, I don't know if that helped. All the addons worked.... I love the changes in the interface. I am very pleased...

#17 Daveman

Daveman

    Critically acclaimed

  • Members
  • 191 posts

Posted 13 October 2014 - 04:02 AM

WOW! THANKS!!! It feels like Christmas! All the changes and enhancements sound awesome!
I especially like .., "Deleting clips (video and audio) from the Cutting Room, now also deletes the related files from your saved movie (if you save it)."


#18 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 13 October 2014 - 09:30 AM

QUOTE (writerly @ Oct 12 2014, 2:40 PM) <{POST_SNAPBACK}>
Multiple restarts. Always bogs down in the same spot. (Just tried it again to be sure.) What do you need from us to help resolve this?

Regards,
C

The boot.log in your Moviestorm user folder should have details of exactly what is going wrong.
It's possible you could go to the 'download' folder within the installation you are trying to update, and see if there are either:
patch-SpecialEffects-25160.jar
or
patch-SpecialEffects-25160.jar.part

If neither exist, then it seems likely that your Moviestorm installation is failing to write to that folder when downloading things.
If the .part file is there, you could delete it, and download the patch-SpecialEffects-25160.jar from our web server at:
http://cloud.moviest...fects-25160.jar
and put it in that folder, then re-run Moviestorm and it would use that file instead of trying to download it again.
Ben Sanders
Moviestorm Ltd

#19 writerly

writerly

    Master Director

  • Pioneers
  • 848 posts

Posted 13 October 2014 - 10:57 AM

Hi Ben

Manually patched the SpecialEffects file. Which got me past that part. Only to have it want another file which I also did. Eventually it got what it wanted then stopped again. The White Progress Bar reads:
"Failed to download TalkShow"
And that's where I gave up.
Here is the boot-log as requested

Moviestorm launcher starting C:\Program Files\Moviestorm1PointSevenOh\.\. Mon Oct 13 06:47:31 EDT 2014
uk.co.moviestorm.msdb.exceptions.DatabaseException: Communication error with remote servlet https://www.moviesto...ceRemoteServlet
at uk.co.moviestorm.msdb.services.user.remote.UserServiceRemote.doRemoteCall(UserSe
rviceRemote.java:926)
at uk.co.moviestorm.msdb.services.user.remote.UserServiceRemote.doRemoteCall(UserSe
rviceRemote.java:844)
at uk.co.moviestorm.msdb.services.user.remote.UserServiceRemote.submitHardwareRepor
t(UserServiceRemote.java:781)
at shortfuze.launcher.Launcher$ReportHardwareTask.run(Launcher.java:1610)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.net.SocketTimeoutException: Read timed out
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(SocketInputStream.java:129)
at com.sun.net.ssl.internal.ssl.InputRecord.readFully(InputRecord.java:293)
at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:331)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:798)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl
.java:1138)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:116
5)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:114
9)
at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:434)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDe
legateHttpsURLConnection.java:166)
at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.ja
va:1014)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnec
tionImpl.java:230)
at uk.co.moviestorm.msdb.services.user.remote.UserServiceRemote.doRemoteCall(UserSe
rviceRemote.java:872)
... 4 more
Downloading http://s3.moviestorm...Valentine.addon
Error downloading http://s3.moviestorm...alentine.addon: Forbidden
Downloading http://s3.moviestorm...d-1.3/1AD.addon
Error downloading http://s3.moviestorm...-1.3/1AD.addon: Forbidden
Downloading http://s3.moviestorm...terBase01.addon
Error downloading http://s3.moviestorm...erBase01.addon: Forbidden
Downloading http://s3.moviestorm...ctionSite.addon
Error downloading http://s3.moviestorm...tionSite.addon: Forbidden
Downloading http://s3.moviestorm...dfighting.addon
Error downloading http://s3.moviestorm...fighting.addon: Forbidden
Downloading http://s3.moviestorm.../TalkShow.addon
Error downloading http://s3.moviestorm...TalkShow.addon: Forbidden




Love the program. I think it is a great filmmaking tool! Glitches happen!
C

#20 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 13 October 2014 - 01:31 PM

The Moviestorm version you are trying to update is trying to get its files from the wrong place, and thus failing to download them. We last updated the download location for Moviestorm version 1.5 (and yours is going to the download-1.3 folder).

Replacing the boot-win.properties or boot-mac.properties with one from a new install would work, I think.
These are found in the boot folder within the installation.
I suspect you may have copied in an old version from somewhere, or that might be a very old copy of Moviestorm.

If you need it to not install all your content packs too, you would need to set
autodownload=yes
and possibly
autoresume=no
in the relevant boot properties file.
Ben Sanders
Moviestorm Ltd


  • Please log in to reply


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users