Jump to content


Photo

Moviestorm 1.6.0 beta available


  • Please log in to reply
80 replies to this topic

#61 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 30 September 2013 - 01:55 PM

QUOTE (daleh @ Sep 28 2013, 9:28 AM) <{POST_SNAPBACK}>
Is this an oversight are did you leave this out of the main packs for a reason, and if not is it something you can sort, doesn't really affect me as I have access photostorm but aren't those packs only available to older users?


Some of the animations in the Photostorms were not entirely functional (and can cause some nasty facial twisting) - they are not in related packs, as they were not associated with the content other than as extras that were used by the specific Photostorm movies. I do not expect them to be appearing outside Photostorm, I'm afraid.
Ben Sanders
Moviestorm Ltd

#62 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 03 October 2013 - 04:06 PM

Added an updated version with a few more fixes.
Ben Sanders
Moviestorm Ltd

#63 alonzo11208

alonzo11208

    Master Director

  • Members
  • 360 posts
  • Gender:Male

Posted 16 October 2013 - 03:55 AM

Any progress on this or the update?
Shadows of Fire
Shadows of Fire Encyclopedia

Creater of Shadows of Fire

#64 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 18 October 2013 - 01:18 PM

Less than there would be if I had not had a cold.

That said, I've made some good progress on allowing additional character models (with their own skeletons). I've got it to the stage where the animations for the extra characters are all optional (rather than being required before the character will appear).
Ben Sanders
Moviestorm Ltd

#65 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5257 posts
  • Gender:Male

Posted 18 October 2013 - 08:30 PM

QUOTE (Ben_S @ Oct 19 2013, 1:18 AM) <{POST_SNAPBACK}>
Less than there would be if I had not had a cold.

That said, I've made some good progress on allowing additional character models (with their own skeletons). I've got it to the stage where the animations for the extra characters are all optional (rather than being required before the character will appear).


Children? Fat people? Animals? He whispers in awe.....wink.gif

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#66 alonzo11208

alonzo11208

    Master Director

  • Members
  • 360 posts
  • Gender:Male

Posted 19 October 2013 - 04:19 AM

We require explanation tongue.gif
Shadows of Fire
Shadows of Fire Encyclopedia

Creater of Shadows of Fire

#67 rampa

rampa

    Master Director

  • Pioneers
  • 1220 posts

Posted 19 October 2013 - 05:00 AM

This is wonderful news Ben! More puppet types! Welcome improvements!

#68 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 01 November 2013 - 12:50 PM

Updated the beta again, with some new sit down anims for sofas, and with the code supporting alternate characters.

Some technical details about adding alternate characters for modders.
Ben Sanders
Moviestorm Ltd

#69 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5257 posts
  • Gender:Male

Posted 02 November 2013 - 12:17 AM

QUOTE (primaveranz @ Sep 22 2013, 4:37 PM) <{POST_SNAPBACK}>
Ben, I am unable to add animations using the "Add Verb/ Prop Solo" route in Modders Workshop. The list of animations always shows up blank now. I have to manually edit the Verbs file and the prop works OK in Moviestorm. I don't think anything else has changed in the way I do things so am attributing it to this Beta release.

I'm still seeing this issue in the latest version.

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#70 rampa

rampa

    Master Director

  • Pioneers
  • 1220 posts

Posted 02 November 2013 - 12:30 AM

Possible solution?

If you are saving your animations from Misfit, that is where the problem is. Export to, or create your animations in Milkshape. Then use the Milkshape CAL3D exporter.

Misfit animations fail to show up. At least for puppets. Not sure about props.

#71 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5257 posts
  • Gender:Male

Posted 02 November 2013 - 01:27 AM

QUOTE (rampa @ Nov 2 2013, 12:30 PM) <{POST_SNAPBACK}>
If you are saving your animations from Misfit, that is where the problem is.


Sadly no. I am a Milkshape man, and it used to work pre-Beta wink.gif

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#72 65radius

65radius

    Director

  • Members
  • 139 posts
  • Gender:Male

Posted 02 November 2013 - 02:51 AM

QUOTE (Ben_S @ Nov 1 2013, 12:50 PM) <{POST_SNAPBACK}>
Updated the beta again, with some new sit down anims for sofas, and with the code supporting alternate characters.


tongue.gif Great new sitting animations! Much more natural!! tongue.gif

#73 tree

tree

    Master Director

  • Pioneers
  • 921 posts

Posted 02 November 2013 - 09:40 AM

QUOTE (primaveranz @ Nov 2 2013, 10:17 AM) <{POST_SNAPBACK}>
I'm still seeing this issue in the latest version.

I think I can reproduce your problem... folders and animation names are "case sensitive' and don't seem to copy across to MS workshop.... So manually put all the capitals in to match the files and directory names... should fix your problem. Good luck :-)


#74 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5257 posts
  • Gender:Male

Posted 02 November 2013 - 09:58 AM

QUOTE (tree @ Nov 2 2013, 9:40 PM) <{POST_SNAPBACK}>
I think I can reproduce your problem... folders and animation names are "case sensitive' and don't seem to copy across to MS workshop.... So manually put all the capitals in to match the files and directory names... should fix your problem. Good luck :-)

Thanks, but I don't think I follow you?
The only place I can manually enter a name for the animation in the Verbs context now is by editing the Verbs file after publishing the addon. Prior to the Beta I could select from a drop down list having first saved the State information for that animation, but now the drop down list is only about 1 character wide and is empty.
Confused I are, as I thought Ben had fixed it in one of the previous Betas...

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#75 tree

tree

    Master Director

  • Pioneers
  • 921 posts

Posted 08 November 2013 - 02:28 AM

simple error report for the nov01 2013 beta version:

Animations not showing up if:


Animations show up if:


This is the same for Props or for building on a new MS skeleton character. Have to choose "All" to get animations to work.

Also another problem: statemachine "Gesture" folder information don't write the correct "case"
more information on this problem at my other forum page: here


#76 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 11 November 2013 - 12:31 PM

QUOTE (primaveranz @ Nov 2 2013, 9:58 AM) <{POST_SNAPBACK}>
Thanks, but I don't think I follow you?
The only place I can manually enter a name for the animation in the Verbs context now is by editing the Verbs file after publishing the addon. Prior to the Beta I could select from a drop down list having first saved the State information for that animation, but now the drop down list is only about 1 character wide and is empty.
Confused I are, as I thought Ben had fixed it in one of the previous Betas...

Just to confirm, on the front screen (with new movie), your copy of the moviestorm beta says r30362 ?
Ben Sanders
Moviestorm Ltd

#77 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 11 November 2013 - 12:35 PM

I'm looking into the Show AddOn filter not showing animations now. The error reproduces for me, too, so it should be fixable once I work out what is happening.
Ben Sanders
Moviestorm Ltd

#78 primaveranz

primaveranz

    Master Director

  • Pioneers
  • 5257 posts
  • Gender:Male

Posted 11 November 2013 - 07:19 PM

QUOTE (Ben_S @ Nov 12 2013, 12:31 AM) <{POST_SNAPBACK}>
Just to confirm, on the front screen (with new movie), your copy of the moviestorm beta says r30362 ?

No it didn't. It seems that my last update failed, thanks for the heads-up.
I just downloaded the zip and tried again. I think it is OK now but will have to create a new model to be sure.
Cheers.

"If we only use 1/3 of our brain, what's the other 1/3 for?"


#79 rampa

rampa

    Master Director

  • Pioneers
  • 1220 posts

Posted 13 November 2013 - 07:56 PM

Hi Ben,

Does this update work on a Mac as well? Should it also show 30362 on the front screen? I occasionally still play with Macintosh, and I am right now.

#80 ArthurVKuhrmeier

ArthurVKuhrmeier

    Master Director

  • Pioneers
  • 492 posts

Posted 14 November 2013 - 08:31 AM

QUOTE (rampa @ Nov 13 2013, 8:56 PM) <{POST_SNAPBACK}>
I occasionally still play with Macintosh, and I am right now.

I always play with MacIntosh... laugh.gif
And yes, it works, I'm on Mac OS X Lion.

Arthur smile.gif


  • Please log in to reply


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users