Jump to content


Photo

graphics problem - help?


  • Please log in to reply
19 replies to this topic

#1 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 01 August 2011 - 05:30 PM

Hi

Just bought the newest MacBook pro 15inch which has a mixed intel/amd radeon graphics engine. (Using Snow Leopard) I seem to have a big problem. The first picture is from my old MacBook. the second is from the new one. I just tried MS to see how it is and the graphics are a mess. This problem is in directors view, camera view, rendering and everything except set view which displays the correct lighting. I've attached the log text so a big shout for help here! sad.gif

Attached File  LOG_copy.txt   31.51KB   1 downloads

Attached File  screen_capture_2.png   204.94KB   4 downloads
Attached File  screen_capture_1.png   309.93KB   3 downloads

#2 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 02 August 2011 - 03:29 AM

I've been playing with this all day and I just cannot get MS to work properly on this computer. As far as I can tell it's a graphics problem, and I want to know; Are intel and amd graphics chips supported by MS. Please let me know this soon as this computer is going to be a giant lemon if you don't these chips.

#3 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 02 August 2011 - 08:01 AM

One thing that occurred to me - the only thing in fact after a large number of coffees - is that I migrated everything including the nvidia cg toolkit to the new computer. Tried deleting it without any effect whatsoever. Getting slightly desperate and am looking at a large hammer now. blink.gif

Paul

#4 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 02 August 2011 - 09:50 AM

Hi Paul
According to the log, the ATI chip is being used; this should be a good thing, as it should be a lot better than the intel one for 3D stuff such as Moviestorm.

I have some sugestions, but we are not quite sure what is going wrong.

Delete your .cache in the Moviestorm user folder - this could have stored shaders that were designed to work on your previous computer/graphics card.

Reinstall the nVidia CG toolkit.

Try changing the graphics settings on the settings screen; possibly disabling any of Depth of Field, Shadows, or hardware skinning. Also check that the depth buffer is set to max, and try changing the Antialiasing or aniostropic filtering.

Try adding or removing light objects to your scene (we did at once stage have a bug that messed up the lighting on ATI cards when there were 4 lights in a scene, with one of the off; I dont think it has been fixed).
Ben Sanders
Moviestorm Ltd

#5 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 02 August 2011 - 10:06 AM

Thanks for the help Ben. I'm not going to be able to try your suggestions out until I get back from work so I'd be grateful if you'd look in on this thread tomorrow.

Cheers,

Paul

#6 Ben_S

Ben_S

    Master Director

  • Mods
  • 4811 posts

Posted 02 August 2011 - 10:13 AM

QUOTE (kibishipaul @ Aug 2 2011, 10:06 AM) <{POST_SNAPBACK}>
Thanks for the help Ben. I'm not going to be able to try your suggestions out until I get back from work so I'd be grateful if you'd look in on this thread tomorrow.

Cheers,

Paul

Sorry; tomorrow I'm going to be on holiday for a week and a half. Will ask Dave to check this thread.
Ben Sanders
Moviestorm Ltd

#7 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 02 August 2011 - 10:22 AM

I'm grateful for whatever help I can get on this one. I tried changing the graphics settings yesterday without much luck, but I'll try out the other things later.

Paul

#8 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 02 August 2011 - 03:45 PM

QUOTE (Ben_S @ Aug 2 2011, 09:50 AM) <{POST_SNAPBACK}>
Delete your .cache in the Moviestorm user folder - this could have stored shaders that were designed to work on your previous computer/graphics card.

Reinstall the nVidia CG toolkit.

Try changing the graphics settings on the settings screen; possibly disabling any of Depth of Field, Shadows, or hardware skinning. Also check that the depth buffer is set to max, and try changing the Antialiasing or aniostropic filtering.

Try adding or removing light objects to your scene (we did at once stage have a bug that messed up the lighting on ATI cards when there were 4 lights in a scene, with one of the off; I dont think it has been fixed).


Tried all these things last night. Result;

a. Can find no such .cache file/document anywhere in MS user file or on this computer.
b. Changing graphics settings has no effect at all.
c. Turning of light objects makes everything darker except faces and exposed surfaces.

What I've noticed; Dark settings with lights have the greatest contrast with most buildings dark and faces/flesh almost white. On daytime settings everything looks normal. Dark settings also sometimes get color casts.

I tried on just intel card which was barely powerful enough to open MS. All problems with contrast/color are with the amd chip.

Attached File  LOG_copy.txt   31.59KB   0 downloads Attached File  boot_copy.log   18.9KB   0 downloads




#9 ArthurVKuhrmeier

ArthurVKuhrmeier

    Master Director

  • Pioneers
  • 492 posts

Posted 02 August 2011 - 05:50 PM

Hi Paul,

you might also try to delete the Mac caches. There are three:
~/Library/Caches
HD/Library/Caches
HD/System/Library/Caches

If I have (minor) problems with Moviestorm, deleting the User caches helps in most of the cases. Recently I deleted all the caches. A few apps asked for minor settings, but my system runs smoother since then.

You can delete the folder or drag it to the desktop, and then restart. Alternatively you can download Onyx and let it do it for you.

Arthur smile.gif

#10 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 03 August 2011 - 07:04 AM

QUOTE (ArthurVKuhrmeier @ Aug 2 2011, 05:50 PM) <{POST_SNAPBACK}>
Hi Paul,

you might also try to delete the Mac caches. There are three:
~/Library/Caches
HD/Library/Caches
HD/System/Library/Caches

Arthur smile.gif


Thanks Arthur. Tried, but no joy.


#11 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 03 August 2011 - 07:08 AM

Re-posting everything I did last night as it got a bit lost in the threads.

Tried all these things last night. Result;

a. Can find no such .cache file/document anywhere in MS user file or on this computer.
b. Changing graphics settings has no effect at all.
c. Turning of light objects makes everything darker except faces and exposed surfaces.

What I've noticed; Dark settings with lights have the greatest contrast with most buildings dark and faces/flesh almost white. On daytime settings everything looks normal. Dark settings also sometimes get color casts.

I tried on just intel card which was barely powerful enough to open MS. All problems with contrast/color are with the amd chip.



#12 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 03 August 2011 - 11:58 AM

Any other suggestions would be appreciated. I'm stumped here as it looks like I've bought myself an a pretty but useless lump of metal sad.gif

#13 kkffoo

kkffoo

    Master Director

  • Pioneers
  • 3288 posts

Posted 03 August 2011 - 12:04 PM

I hope this can be sorted for you Paul.

#14 ArthurVKuhrmeier

ArthurVKuhrmeier

    Master Director

  • Pioneers
  • 492 posts

Posted 03 August 2011 - 05:35 PM

QUOTE (kibishipaul @ Aug 3 2011, 07:08 AM) <{POST_SNAPBACK}>
a. Can find no such .cache file/document anywhere in MS user file or on this computer.

Hi Paul,

good news! smile.gif I found the ".cache" Folder. It is a hidden folder in your "Moviestorm" folder in your home directory. To make it visible -- I use Mac OS X 10.6 -- but it's the same in 10.5:

1. Goto you home directory, open the "Moviestorm" folder.
2. Select "File > Find" or CMD-F.
3. Enter ".cache" in the search field.
4. Below choose "Search: Moviestorm" (not "This Mac").
5. Below is the result filter. Click on "Kind" and select "Other...".
6. In the list find "File invisible" and double-click it. (On 10.4 it should be "Visibility".)
7. Now the result filter is set to "Visible Items". Simply change that to "Visible or Invisible".
8. Be happy! laugh.gif Finally you got the search result you wanted: the hidden folder ".cache".
9. You can either delete the folder or open it and delete the files. I couldn't rename the folder but was able to copy it.

I hope you can find the folder, and hopefully solve that graphics hick-up...
Arthur smile.gif

#15 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 04 August 2011 - 07:03 AM

QUOTE (ArthurVKuhrmeier @ Aug 3 2011, 05:35 PM) <{POST_SNAPBACK}>
Hi Paul,

good news! smile.gif I found the ".cache" Folder. It is a hidden folder in your "Moviestorm" folder in your home directory. To make it visible -- I use Mac OS X 10.6 -- but it's the same in 10.5:

1. Goto you home directory, open the "Moviestorm" folder.
2. Select "File > Find" or CMD-F.
3. Enter ".cache" in the search field.
4. Below choose "Search: Moviestorm" (not "This Mac").
5. Below is the result filter. Click on "Kind" and select "Other...".
6. In the list find "File invisible" and double-click it. (On 10.4 it should be "Visibility".)
7. Now the result filter is set to "Visible Items". Simply change that to "Visible or Invisible".
8. Be happy! laugh.gif Finally you got the search result you wanted: the hidden folder ".cache".
9. You can either delete the folder or open it and delete the files. I couldn't rename the folder but was able to copy it.

I hope you can find the folder, and hopefully solve that graphics hick-up...
Arthur smile.gif



Hi Arthur

Tried this out and followed your instructions to the letter but nothing appeared in the search box. sad.gif

Paul

#16 kibishipaul

kibishipaul

    Master Director

  • Pioneers
  • 427 posts

Posted 04 August 2011 - 08:11 AM

Finally got some traction on this one. Decided to delete everything MS from my hard drive and reinstall from scratch. It seems to have worked. I made a new movie and I'm not having any of the horrible contrast problems of the past few days. I haven't put in all of my third party mods or tried out any of my old sets yet but for the moment it's working laugh.gif

Thanks to everyone who has helped on this. wink.gif

Paul

#17 warmanivan

warmanivan

    Wannabe film-maker

  • Pioneers
  • 45 posts

Posted 04 August 2011 - 08:46 AM

QUOTE (kibishipaul @ Aug 4 2011, 08:11 AM) <{POST_SNAPBACK}>
Finally got some traction on this one. Decided to delete everything MS from my hard drive and reinstall from scratch. It seems to have worked. I made a new movie and I'm not having any of the horrible contrast problems of the past few days. I haven't put in all of my third party mods or tried out any of my old sets yet but for the moment it's working laugh.gif

Thanks to everyone who has helped on this. wink.gif

Paul



awesome!

#18 Dave

Dave

    Critically acclaimed

  • Mods
  • 218 posts

Posted 04 August 2011 - 09:32 AM

Glad to hear you got it working! (I don't know anyone here with the latest gen of MBP and was about to give the Apple Store a ring to see if I could borrow one of theirs...)

Chief Bit Shoveller
Short Fuze Ltd

#19 keithlawrence

keithlawrence

    Master Director

  • Pioneers
  • 1145 posts

Posted 04 August 2011 - 09:54 AM

QUOTE (Dave @ Aug 4 2011, 11:32 AM) <{POST_SNAPBACK}>
(I don't know anyone here with the latest gen of MBP and was about to give the Apple Store a ring to see if I could borrow one of theirs...)

Maybe you can call them anyway and have them give you the latest iMac so that you can confirm MS doing well on it laugh.gif

Glad to hear good progress, Paul

#20 ArthurVKuhrmeier

ArthurVKuhrmeier

    Master Director

  • Pioneers
  • 492 posts

Posted 04 August 2011 - 10:22 AM

QUOTE (kibishipaul @ Aug 4 2011, 07:03 AM) <{POST_SNAPBACK}>
Tried this out and followed your instructions to the letter but nothing appeared in the search box. sad.gif


Hi Paul,

I'm glad you made it! smile.gif Probably your Moviestorm folder was corrupted in some way. So, it was a good idea to delete the whole thing.

And now... let it storm...
Arthur biggrin.gif


  • Please log in to reply


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users