Jump to content


Photo

Moviestorm 1.4.1 released


  • Please log in to reply
51 replies to this topic

#1 Moviestorm

Moviestorm

    Master Director

  • Mods
  • 533 posts

Posted 09 September 2010 - 05:46 PM

Moviestorm 1.4.1 is now available free to all users. To get it, just start Moviestorm as normal and it will update automatically. You may need to wait up to 30 seconds, so don’t press the Start button too soon!

Note: If you’ve already installed the Moviestorm 1.4 early access release, you don’t need to do anything special with either boot-win.properties or boot-mac.properties this time. Moviestorm 1.4 will just install as normal.

This release includes a few new features, and a lot of updates to the features introduced in Moviestorm 1.4. Most importantly for Mac users, it now runs on Tiger (OS X 10.4) or Leopard (OS X 10.5).

For first-time users, we’ve added eight new starter movies. These are short movie templates that provides a starting point for you to play with Moviestorm and easily create a compelling movie. Customise as much as you wish and add your own ending. You can change the characters in the Dressing Room View, adjust the set in the Set Workshop, or go to the in Director’s View and click on events on the Timeline, to move, delete or customise character actions, and any dialogue. Adjust your camera cuts in the Camerawork View to fit your changes, and finally, add all your new footage in the Cutting Room View before rendering your movie and uploading it to share with your friends in the Publisher’s View.

Starter movies cover many genres: romance, gangsters, horror,and science fiction. But of course, you can easily switch them around, and turn that spooky chiller into a comedy or do a political broadcast instead of a blog.

New features
- Moviestorm now remembers the sort option on the Load Movie screen.
- Movie templates on the New Movie screen are now arranged by category rather than by content pack.
- Characters in the Dressing Room View now have a placement mark at their feet. To change the color of the mark, left-click it.
- Modding: Bodyparts with the same name in different addons are now merged together; this allows modders to add extra materials or decals to existing bodyparts such as the Universal Heads.

Resolved issues
- Moviestorm now runs on Macs running Tiger (OS X 10.4) or Leopard (OS X 10.5).
- Target shots on slow walks, or on runs, no longer causes camera jumps.
- A framerate slowdown caused by stacking lots of objects on top of each other has been fixed.
- Deleting windows, fireplaces or doors no longer results in other objects attached to the relevant wall vanishing.
- Backup files for a movie can now still be created even if you have ten backups already.
- Combining depth of field, cel shading and the new Universal Heads no longer breaks the 3D view.
- Can now drag a characters marks around in the Director’s view after the movie was saved in another view.
- The held prop panel no longer goes blank when you change the colour of the held prop.
- Eyes no longer vanish when looked at through transparent objects (such as glasses, hair or windows).
- When you create a new scene, you will now be offered a choice of sets.
- The lighting direction in the lighting panel is updated correctly when selecting a preset lighting option.

Known issues
- Moviestorm no longer loads in the view from which you saved the movie.
- Eyes that pop out: Users with BaseBeta2, Pioneer01, MaleCostumes01 or FemaleCostumes01 will need to download and reinstall these Content Packs if they wish to continue to use them. While these packs are not longer supported, they have been updated with the animations which have been modified to fix a bug which caused characters eye to pop out.

Full release notes available here.

Stormfellas starter movie
The Moviestorm Team

#2 lucindamc123

lucindamc123

    Master Director

  • Pioneers
  • 9177 posts

Posted 09 September 2010 - 05:52 PM

For those of us who already installed 1.4, will this efffect the movies on which we are currently working?

#3 kkffoo

kkffoo

    Master Director

  • Pioneers
  • 3288 posts

Posted 09 September 2010 - 06:13 PM

Thank you for fixing eyes , looking good!

I got a universal head eye-cube thingy missing asset on one of my 1.4 movies. Reverting made no difference. I've had that error in 1.4, seems a bit random.

#4 Moviestorm

Moviestorm

    Master Director

  • Mods
  • 533 posts

Posted 09 September 2010 - 06:22 PM

QUOTE (lucindamc123 @ Sep 9 2010, 05:52 PM) <{POST_SNAPBACK}>
For those of us who already installed 1.4, will this efffect the movies on which we are currently working?


Shouldn't do, but you may wish to play it safe.
The Moviestorm Team

#5 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 06:40 PM

I started MS 1.4--I did not hit the start button--waited 10 minutes. No update to 1.4.1 is occurring. I did this several times.

iMac 2.66-4gb-snow leopard 10.6.4

#6 mystery_egypt

mystery_egypt

    Master Director

  • Pioneers
  • 926 posts

Posted 09 September 2010 - 07:17 PM

Awww, not again peet, so sorry that you are still/again experiencing issues sad.gif


Update on my Vista laptop went apparently smoothly, now I'll be testing the functionality and bug fixes in the next days.

#7 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 07:46 PM

QUOTE (mystery_egypt @ Sep 9 2010, 07:17 PM) <{POST_SNAPBACK}>
Awww, not again peet, so sorry that you are still/again experiencing issues sad.gif


Update on my Vista laptop went apparently smoothly, now I'll be testing the functionality and bug fixes in the next days.



Thanks for the update on how well Moviestorm installs on a PC.

#8 scripter

scripter

    Wannabe film-maker

  • Members
  • 47 posts

Posted 09 September 2010 - 08:40 PM

I had problems when installing the initial patch. I never got it to work. The new update didn't work either, until...

I totally removed MovieStorm from my PC. I then started fresh, and downloaded MovieStorm from the download page. The new update installed automatically and it works like a dream!

I'm absolutely loving it now.

If you have problems, like I first had, maybe you should start a-fresh. It worked for me and I had a nightmere at the start - trying everything.

I.4 is certainly a force to be reckoned with.

Bravo!

Master Mind

#9 kv

kv

    Master Director

  • Pioneers
  • 1941 posts

Posted 09 September 2010 - 09:00 PM

I`m gonna have a tinker with this now before I go to bed, first question though, why do all the 3rd party mods show "Buy" next to the "installed" status in Get more content? blink.gif

#10 mystery_egypt

mystery_egypt

    Master Director

  • Pioneers
  • 926 posts

Posted 09 September 2010 - 09:07 PM

QUOTE (peet @ Sep 9 2010, 07:46 PM) <{POST_SNAPBACK}>
Thanks for the update on how well Moviestorm installs on a PC.

I hope you didn't misunderstand the second part of my post as bragging towards you unsure.gif
That part was merely a feedback towards the MS team.

#11 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 09:21 PM

QUOTE (Moviestorm @ Sep 9 2010, 05:46 PM) <{POST_SNAPBACK}>
Moviestorm 1.4.1 is now available free to all users. To get it, just start Moviestorm as normal and it will update automatically. You may need to wait up to 30 seconds, so don’t press the Start button too soon!

Note: If you’ve already installed the Moviestorm 1.4 early access release, you don’t need to do anything special with either boot-win.properties or boot-mac.properties this time. Moviestorm 1.4 will just install as normal.

This release includes a few new features, and a lot of updates to the features introduced in Moviestorm 1.4. Most importantly for Mac users, it now runs on Tiger (OS X 10.4) or Leopard (OS X 10.5).

For first-time users, we’ve added eight new starter movies. These are short movie templates that provides a starting point for you to play with Moviestorm and easily create a compelling movie. Customise as much as you wish and add your own ending. You can change the characters in the Dressing Room View, adjust the set in the Set Workshop, or go to the in Director’s View and click on events on the Timeline, to move, delete or customise character actions, and any dialogue. Adjust your camera cuts in the Camerawork View to fit your changes, and finally, add all your new footage in the Cutting Room View before rendering your movie and uploading it to share with your friends in the Publisher’s View.

Starter movies cover many genres: romance, gangsters, horror,and science fiction. But of course, you can easily switch them around, and turn that spooky chiller into a comedy or do a political broadcast instead of a blog.

New features
- Moviestorm now remembers the sort option on the Load Movie screen.
- Movie templates on the New Movie screen are now arranged by category rather than by content pack.
- Characters in the Dressing Room View now have a placement mark at their feet. To change the color of the mark, left-click it.
- Modding: Bodyparts with the same name in different addons are now merged together; this allows modders to add extra materials or decals to existing bodyparts such as the Universal Heads.

Resolved issues
- Moviestorm now runs on Macs running Tiger (OS X 10.4) or Leopard (OS X 10.5).
- Target shots on slow walks, or on runs, no longer causes camera jumps.
- A framerate slowdown caused by stacking lots of objects on top of each other has been fixed.
- Deleting windows, fireplaces or doors no longer results in other objects attached to the relevant wall vanishing.
- Backup files for a movie can now still be created even if you have ten backups already.
- Combining depth of field, cel shading and the new Universal Heads no longer breaks the 3D view.
- Can now drag a characters marks around in the Director’s view after the movie was saved in another view.
- The held prop panel no longer goes blank when you change the colour of the held prop.
- Eyes no longer vanish when looked at through transparent objects (such as glasses, hair or windows).
- When you create a new scene, you will now be offered a choice of sets.
- The lighting direction in the lighting panel is updated correctly when selecting a preset lighting option.

Known issues
- Moviestorm no longer loads in the view from which you saved the movie.
- Eyes that pop out: Users with BaseBeta2, Pioneer01, MaleCostumes01 or FemaleCostumes01 will need to download and reinstall these Content Packs if they wish to continue to use them. While these packs are not longer supported, they have been updated with the animations which have been modified to fix a bug which caused characters eye to pop out.

Full release notes available here.

Stormfellas starter movie



Since I was unable to update my copy of MS 1.4 (please don't reply with a comment on how to do this as I already know how-read my previous post). I went ahead and downloaded what I thought was going to be 1.3.0.2 (link labeled as 1.3.0.2 on the website). As it turns out the link is now 1.4.1. OK. So I installed 1.4.1 in a separate folder from 1.4.

I didn't want to complicate matters with saved movies so I started a new movie and then selected a scene. Some scenes simply load as a white screen. If a scene does load properly (or it looks as though it did) it defaults to the Workshop View. When I select a different view from the menu items at the top of the screen, all the menu items disappear. When I try and quit Moviestorm it freezes and I then have to "force quit".

Is Moviestorm going to be capable of running on a Mac anytime soon?






#12 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 09:24 PM

QUOTE (scripter @ Sep 9 2010, 08:40 PM) <{POST_SNAPBACK}>
I had problems when installing the initial patch. I never got it to work. The new update didn't work either, until...

I totally removed MovieStorm from my PC. I then started fresh, and downloaded MovieStorm from the download page. The new update installed automatically and it works like a dream!

I'm absolutely loving it now.

If you have problems, like I first had, maybe you should start a-fresh. It worked for me and I had a nightmere at the start - trying everything.

I.4 is certainly a force to be reckoned with.

Bravo!



If you are commenting on what I said---I have a MAC not a PC. Also look at my last post.

#13 willshetterly

willshetterly

    Master Director

  • Pioneers
  • 1356 posts

Posted 09 September 2010 - 10:37 PM

QUOTE (peet @ Sep 9 2010, 06:40 PM) <{POST_SNAPBACK}>
I started MS 1.4--I did not hit the start button--waited 10 minutes. No update to 1.4.1 is occurring. I did this several times.

iMac 2.66-4gb-snow leopard 10.6.4

Just for a data point, I'm using an iMac 2.93 with 10.6.4, and I didn't have any problems. But it's possible I'm using a different installation of the CG Toolkit than you are. Good luck!

#14 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 11:24 PM

QUOTE (mystery_egypt @ Sep 9 2010, 09:07 PM) <{POST_SNAPBACK}>
I hope you didn't misunderstand the second part of my post as bragging towards you unsure.gif
That part was merely a feedback towards the MS team.



No, I didn't take it as bragging or "in yo face", and I'm not offended.


#15 jakechief

jakechief

    Master Director

  • Pioneers
  • 360 posts

Posted 09 September 2010 - 11:27 PM

I know others have had problems and started fresh, but I have started fresh way too many damn times. The thing is moviestorm, like my last moviestorm one I tried to do fresh, said there was a bug. Now, I am just sick and tired of all these bugs I am getting. I hate re-freshing my moviestorm, as I was in the middle of a scene! What am I suppose to do?
Radio host of "The Storm Hour" Saturdays at 1 Pacific, 3 Central, 4EST, 9Uk, 10EUR, only on www.tmoaradio.com

#16 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 11:49 PM

QUOTE (willshetterly @ Sep 9 2010, 10:37 PM) <{POST_SNAPBACK}>
Just for a data point, I'm using an iMac 2.93 with 10.6.4, and I didn't have any problems. But it's possible I'm using a different installation of the CG Toolkit than you are. Good luck!



I have tried 3 different versions of the toolkit. The last one I installed was cg-3 0007.

#17 peet

peet

    Upcoming director

  • Members
  • 79 posts
  • Gender:Male

Posted 09 September 2010 - 11:59 PM

QUOTE (willshetterly @ Sep 9 2010, 10:37 PM) <{POST_SNAPBACK}>
Just for a data point, I'm using an iMac 2.93 with 10.6.4, and I didn't have any problems. But it's possible I'm using a different installation of the CG Toolkit than you are. Good luck!



You don't have any problems with Moviestorm crashing or freezing?

#18 willshetterly

willshetterly

    Master Director

  • Pioneers
  • 1356 posts

Posted 10 September 2010 - 01:39 AM

QUOTE (peet @ Sep 9 2010, 11:59 PM) <{POST_SNAPBACK}>
You don't have any problems with Moviestorm crashing or freezing?

No, but I haven't had time to do a proper movie in a while. I start it up for each new version and play a little, admiring the changes, but I haven't given the most recent versions a thorough workout.

I forget where the toolkit is installed. If you can tell me, I'll let you know which version I'm using.

#19 lucindamc123

lucindamc123

    Master Director

  • Pioneers
  • 9177 posts

Posted 10 September 2010 - 01:53 AM

Just updated to 1.4.1 using the version of 1.4 that was buggy that I had updated from an existing 1.3 version with all my user made addons and it is working perfectly now. No problems at all. And the shaders now work.

#20 neut

neut

    Master Director

  • Pioneers
  • 348 posts

Posted 10 September 2010 - 09:29 AM

I'm using a macbook pro with snow leopard. The update went very smoothly no problems at all. Moviestorm opened up with no probs everything seems to be okay.

I was hoping though that we could add our own images to the actors faces in the dressing room. I still haven't been able to figure out where to change them in the folders.

Any ideas?

neut smile.gif


  • Please log in to reply


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users