Jump to content


Huffyuv Render for Sony Vegas on a Win7 64 bit System

  • Please log in to reply
2 replies to this topic

#1 Nahton


    Master Director

  • Pioneers
  • 930 posts

Posted 23 August 2013 - 05:50 PM

EDIT: Just to be clear on the purpose of this thread: It is intended to assist those of us who prefer to render our Moviestorm videos using the Huffyuv codec and import the rendered video into Sony Vegas. This has been the topic of a number of threads over the years and I wanted to document the steps I took that enabled me to successfully accomplish this.

First off, I need to state that what works for one may not work for others and what worked for me may not exactly be so easily identifiable. Sounds great, doesn't it? I'll bet you are all in on this now. Actually, while I may not be able to say with 100 percent certainly what worked I can make a fair assumption what did and hopefully provide a path others can repeat. To be clear, this solution enabled me to import Huffyuv renders with the sound in perfect synch for a 30 second test clip.

Here's my situation. I had to put a fresh install of Win7 on my laptop due to a corrupted boot sector. This also meant I needed fresh installs of both Moviestorm and Sony Vegas (Movie Studio Platinum 9.0) I did restore data files from a backup I had but that should not have affected the system files. I was working with as pristine an environment as one could have and I could not render and import Huffyuv renders.

My first stop on my "Google Quest" to find a solution was at this LifeHacker Post where I learned when it comes to codec packs, less can be best and more can just cause more problems. That caused me to start off taking a conservative an approach as possible, which for me meant just trying to find an isolated solution for installing a huffyuv codec.

Step #1:
I first tried the solution offered in this YouTube video to install the Huffyuv codec on a Win7 64 bit PC. It did not work on it's own but may be needed in combination with other actions.

Step #1A
I tried this command prompt method of installing the Huffyuv codec. In the end I believe it was just another way of accomplishing what I did in step 1, which was a far easier method IMO. BTW - it still wasn't working.

Step 2:
I saw this post on another user who got it to work by installing the 64 bit Huffyuv codec in the System32 folder rather than the syswow64 folder. I tried this by using the method in Step 1 for the system32 folder install. It still wasn't working.

Side note:
At this point I rendered a video clip using the AVI legacy option and realized that my problem wasn't limited to just Huffyuv Avi files as Vegas did not import any video for this avi file either. At this point I threw some caution to the wind and went "Mega".

Step 3:
I downloaded the K-Lite Mega Codec Pack 10.0.0 and installed it. Following that I was able to render and import sound and video into Sony Vegas. Important note: Step through this install slowly and review each screen. Select "default without player" at the start. At one point you will see a list of codecs with some being checked and others not. Scroll down until you find Huffyuv. It will be unchecked. Make sure you check the box. Later on you will be presented with 3 check boxes you will need to clear to avoid installing AVG anit-virus and some other features.

So what do I recommend for others? I would suggest trying Step 1 and then Step 3. If that doesn't work try step 2 as well. I don't believe it hurts in any way since it points to another folder so if you can opt to take steps 1 -3 at once and then test your render and import. If these don't work you might want to double back and try step 1A.

I'd be interested to hear if this works for anyone who hasn't been able to get it to work thus far. There are no guarantee's but I figured I'd offer this up to everyone since it worked for me. Good Luck!

#2 Nahton


    Master Director

  • Pioneers
  • 930 posts

Posted 13 November 2013 - 01:12 PM

I revisited this on yet another PC rebuild and I've updated the original post. I noticed the K-Lite pack is attempting to install additional applications but they can be deselected during the installation. I don't believe that was the case on the prior version of the codec pack.

I once again went through steps 1, 1A and 3. I actually tried just step 3 first and it didn't work so I circled back and tried 1 and 1A and tested each step of the way. When I was done it didn't work!

I went back and stepped through the K-Lite install again and noticed that in the default installation Huffyuv is not selected. I've modified the original post in this thread to highlight that point. I selected the default without the player option to try to minimize any potential for codec overload problems. Once I installed the K-Lite pack with Huffyuv selected I was able to import a previously rendered Moviestorm 30 second clip into Sony Vegas. That verifies that the Moviestorm export of Huffyuv is functioning fine and the problem lies with importing into Sony Vegas.

Based on this last experience I recommend trying just step 3 and then testing your Vegas Huffyuv import.

#3 Nahton


    Master Director

  • Pioneers
  • 930 posts

Posted 20 November 2013 - 02:11 AM

And now the caveat....

I based my prior declaration this solution worked based on doing a 30 second test render. Last night I tried rendering a 3 minute plus video. The sound import into Vegas did not work. I then tested different length movies starting at a length of 1 minute. Once again the sound did not render for import into Vegas. I tried 45 seconds and the sound rendered. I performed 4 more 45 second length renders and the sound import worked for each one.

I would presume this indicates the problem lies with the Moviestorm render process. I will try using a video format converter on the failed renders to see if I can convert them with full audio just to confirm this.

I find this level of functionality acceptable but I would prefer to get to a length of at least a minute.

More later...

  • Please log in to reply

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users