Jump to content


Photo

Re-texturing head and body (new problem)


  • Please log in to reply
19 replies to this topic

#1 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 27 November 2009 - 12:05 PM

Hi, i need to re-texture a head and body and save as new.
I follow instrucctions from other post and wiki, but this is a hell.

First i read the wiki:
QUOTE
"With Moviestorm NOT running, browse to Moviestorm/Addon/Core/Data/Puppets/Male01 and locate the BODYPART file named Head Euro Young"


Ok thats is strange, i follow the rute in win directory and also into the Modshop and not appears any bodypart file, only found the textures dds. and i like to add new heads in Moviestorm re-texturing, is posible? I'm running in Windows Vista.

I read also the tutorial of davidmount, about re-texturing heads (great work) but i'm blocked, the images not explain the detail process to get there into modshop.

I don't have any problem with modify textures dds. I have photoshop and plugin, but the problem is after make this textures, steps are presented unknown or difficult to follow.

¿Don't think it's time to make a good guide for this? or videotutorial.

¿Can anyone help me? i appreciate this.
Thanks for all smile.gif

Greetings!

#2 daleh

daleh

    Master Director

  • Pioneers
  • 810 posts

Posted 27 November 2009 - 01:41 PM

I just had a quick look at this for you and you are correct....it seems they have changed where some data is stored now with the new 1.2 version, this happens often, they change something so the wiki gets out of date until someone updates it.

It seems that the heads are now stored in the new 'ModdersWorkshop' addon under the following path.

/Addon/ModdersWorkshop/Data/Puppets/Male/

Just so you know for the future theres a very easy way to find stuff, i assume you have a modders license and access to the Modders Workshop?

anyway, when in the Modders Workshop any item, be it a prop, head, costume, beard, hair etc etc, you can right click on it and choose 'Show File In Browser', this will open up the actual windows folder where that items template is stored.

As for the wiki and other modding guides, i think they are maintained by some of the more experienced modders here, on their own free time....so please be patient and i am sure someone will be doing updates to it once they have the time, and have had time to study all the new changes that came in 1.2





#3 Nahton

Nahton

    Master Director

  • Pioneers
  • 930 posts

Posted 27 November 2009 - 01:45 PM

DemianFox,

I am running XP but here is the patht to where I find those files:

C:\Program Files\Moviestorm Release\AddOn\Core\Data\Puppets\Male01



#4 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 27 November 2009 - 02:39 PM

Wuow, is very strange. I don't see any bodypart file. ¿What is the name of the extension of a bodypart file?
¿Is possible that the Modshop don't working well in windows and only works in Mac os?

daleh, I have the new 1.2 version and i don't see any folder called ModdersWorkshop in Addon.
And i have the modder's workshop and licence operative.

welcome to the labyrinth biggrin.gif

#5 Reacher

Reacher

    Master Director

  • Pioneers
  • 307 posts

Posted 27 November 2009 - 03:20 PM

QUOTE (DemianFox @ Nov 27 2009, 08:39 AM) <{POST_SNAPBACK}>
Wuow, is very strange. I don't see any bodypart file. ¿What is the name of the extension of a bodypart file?
¿Is possible that the Modshop don't working well in windows and only works in Mac os?

daleh, I have the new 1.2 version and i don't see any folder called ModdersWorkshop in Addon.
And i have the modder's workshop and licence operative.

welcome to the labyrinth biggrin.gif


In 1.2 the modshop must be downloaded separately, I haven't upgraded yet, but the post explaining it is here:
http://www.moviestor...;showtopic=6967

-- Reacher

#6 johnnie

johnnie

    Master Director

  • Pioneers
  • 860 posts

Posted 27 November 2009 - 04:10 PM

QUOTE (Reacher @ Nov 27 2009, 03:20 PM) <{POST_SNAPBACK}>
In 1.2 the modshop must be downloaded separately, I haven't upgraded yet, but the post explaining it is here:
http://www.moviestor...;showtopic=6967

-- Reacher


Not quite. The Modders Workshop is still contained within Moviestorm in the same way it always was. What we've separated out, as of version 1.2, is the data which the modshop needs. In order to get this data (without which the Modders Workshop is of little practical use!) just download and install the new ModdersWorkshop.addon.

Johnnie Ingram
Co-Author, Machinima For Dummies

QUOTE (The Overcast @ July 23 2006)

#7 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 27 November 2009 - 04:42 PM

Well, first point fixed! that was the problem, i had the Modshop installed but not the data.
I can follow the steps now.

Thanks for all biggrin.gif

#8 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 01 December 2009 - 04:46 PM

however hard they try there is no way. heads always appear in black and a new icon that says BROKEN.



Help please!
Thanks for all laugh.gif

#9 AngriBuddhist

AngriBuddhist

    Master Director

  • Pioneers
  • 2074 posts

Posted 01 December 2009 - 05:11 PM

Demian, I'm the author of the wiki article about retexturing a puppet. There are many small things that could have gone wrong with this. The easiest way to troubleshoot this is if you open the Modshop, open the Bodypart's template, Save it, then Publish and Pack the addon and email it to me. I'll have a look and hopefully be able to tell you where it went wrong.

It's way past bedtime for me and I have things to do for the first part of my day. So, it'll probably be 24 hours until I get back to you. If that's ok, check your Inbox for my email address.

#10 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 01 December 2009 - 05:58 PM

Thanks Angri well you were right! I had forgotten to do some things of your wiki article.
I finally have done right! laugh.gif



#11 willshetterly

willshetterly

    Master Director

  • Pioneers
  • 1356 posts

Posted 01 December 2009 - 08:18 PM

Good work! I'm always glad to see people modding heads to add more variety to what's currently available.

#12 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 09 January 2010 - 06:46 PM

I have a new problem with the re-texturing.
I textured the head putting four possible variations. Changing only the diffuse value. When I save everything and open the Moviestorm, this is all right I have four heads as possible with their textures, but in the last two texture of the body becomes white when the head is black.





Does anyone know the solution of this problem?
Thanks: D

#13 steelblade

steelblade

    Master Director

  • Pioneers
  • 728 posts

Posted 10 January 2010 - 12:01 AM

QUOTE (DemianFox @ Jan 9 2010, 06:46 PM) <{POST_SNAPBACK}>
I have a new problem with the re-texturing....

Does anyone know the solution of this problem?
Thanks: D


Have a look at this. I have been trying to get it uploaded to a mod site, but can't seem to get an answer from anyone.

Attached Files



#14 AngriBuddhist

AngriBuddhist

    Master Director

  • Pioneers
  • 2074 posts

Posted 10 January 2010 - 04:27 AM

My best guess would be the "Skin Tint Matching".

If correct, MS is trying to tint the body of the character with the color from the head. With darker colors you may not see much (if any) difference but with the amount of white you have (including the somewhat transparent white) MS can't pick out just the darker color and is creating the oddity you are seeing.

#15 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 10 January 2010 - 09:57 AM

¿And how could I fix it?
I need the color of the head matches the body. laugh.gif

#16 AngriBuddhist

AngriBuddhist

    Master Director

  • Pioneers
  • 2074 posts

Posted 10 January 2010 - 10:13 AM

Fix it?

If that's the problem, you'd need to change the coloring of your textures. Avoid using too many light colors when making head textures for darker toned models and not using darker colors when when making head textures for lighter toned models.

Also, I understand what you want to achieve with the light white paint on the face but it's probably not gonna work with the way that MS currently does things.



#17 DemianFox

DemianFox

    Film Critic

  • Members
  • 15 posts

Posted 10 January 2010 - 01:45 PM

It is another thing! I used the original texture with no additions and the same problem. The body is white and this only happens with the last two textures. There must be something else. But I think, do only heads of two variants or one.



Thanks

#18 Reacher

Reacher

    Master Director

  • Pioneers
  • 307 posts

Posted 10 January 2010 - 04:00 PM

Check your .bodypart file. Make sure each alternate material has a skinTint entry similar to:
CODE
          <parameters>
             <entry>
                 <string>skinTint</string>
                 <Color4f>0.5887 0.2367 0.2832 1.0</Color4f>
               </entry>
             </parameters>

See here for how to calculate the values of the Color4f entry. In your case they may be the same as your other two if the base skin tone is the same.

-- Reacher

#19 czechboysonic

czechboysonic

    Master Director

  • Pioneers
  • 319 posts

Posted 11 January 2010 - 08:57 AM

Seems we come up with questions about this every few months (really should sticky the thread somewhere hehe).

Did some retexturing aaaaaaaaaaaaages ago (version 1.0.something so the assets have moved slightly in MS asset tree as noted), and made up some handy Photoshop templates with a co-ordinate system that should help you orient your textures on the bodies.

Original post explaining how to do it is here http://www.moviestor...p...ost&p=19393

Photoshop Assets attached.

Attached Files



#20 ed

ed

    Master Director

  • Pioneers
  • 373 posts

Posted 04 May 2010 - 09:30 AM

QUOTE (Nahton @ Nov 27 2009, 01:45 PM) <{POST_SNAPBACK}>
DemianFox,

I am running XP but here is the patht to where I find those files:

C:\Program Files\Moviestorm Release\AddOn\Core\Data\Puppets\Male01

I ran in to the same problem: it seems that the Modder's Workshop button will appear if the last logged-in user on your installation (probably you) has a Modder's Workshop licence. Because the Modder's Workshop button was visible on my launch screen, I assumed (wrongly) that simply installing MS 1.2 was enough, and that the Modder's Workshop thing was taken care of automagically. It wasn't, hence my confusion.

Users of 1.2 and 1.3 who want to use the Modder's Workshop will have to downloaded and install the new Modder's Workshop addon, even if (especially if) they have used the Modder's Workshop before; after intalling the addon, Moviestorm will prompt the user to get some 1.2 updates (I don't know about 1.3 as I'm not using that version on this particular machine) and that will sort things out.

After installing the ModdersWorkshop addon, the AddOn\ModdersWorkshop directory is created and a whole bunch of bodypart files will appear in the directories below.

There's a link to the ModdersWorkshop addon here: http://www.moviestor...p...5&pid=57798


  • Please log in to reply


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users